FAQ

System requirements

Windows 7, Windows 8, Windows 10

The minimum configuration for using of the MAGNET Products under Windows is:

  • 2 GHz or faster processor
  • 8 GB system memory and 500 MB free hard disk space
  • OpenGL compatible professional 3D graphics card. See note in chapter 1.1.3.
  • Microsoft .NET Framework v4.0. .NET Framework v4.0 can be downloaded from www.microsoft.com 
  • Installing latest Windows updates and fixes from Microsoft is recommended

Note! Windows Vista must have "Visual C++ 2010 Redistributable" installed (x64 bit version)

Supported AutoCAD versions (MAGNET Modeler for Autodesk)

To install MAGNET Modeler, you need to have an Autodesk AutoCAD product installed.

The following versions are supported:

  • AutoCAD
  • AutoCAD Map3D
  • AutoCAD Civil 3D 2017, 2018 or 2019

 

Recommended graphics cards

  • OpenGL compatible professional 3D graphics card such as NVIDIA Quadro® or ATI FireGL™ / AMD FirePro™
  • Upper end gaming cards such as NVIDIA GeForce® and AMD Radeon™ 
  • Make sure you have the latest graphics cards drivers installed. These can be downloaded from the manufacturers web pages like www.nvidia.com or www.amd.com

Graphics cards that are meant for office and basic 2D uses are not recommended as they have limited 3D-graphics capabilities. These not recommended cards include NVIDIA NVS, ATI FireMV and all lower end integrated graphics chipsets like Intel G/GM. They don’t perform well with bigger models.